В iPhone нашли уязвимость для отката прошивки и джейлбрейка

Хакер axi0mX выложил в открытый доступ эксплойт Checkm8, который может взломать большинство устройств на iOS. В последний раз аналогичную уязвимость находили в 2010 году.

Эксплойт можно запустить на всех устройствах с чипами A5 – A11. Среди них iPhone 4S – iPhone X, iPad 2 – iPad 2019 и iPod touch 5 – 7.

Checkm8 использует загрузчик Bootrom, поэтому Apple не сможет устранить уязвимость, выпустив новую версию iOS.

Bootrom прошивается в память устройства ещё на заводе. Он активируется каждый раз при загрузке iPhone и iPad. Обновления iOS не затрагивают Bootrom.

EPIC JAILBREAK: Introducing checkm8 (read "checkmate"), a permanent unpatchable bootrom exploit for hundreds of millions of iOS devices.

Most generations of iPhones and iPads are vulnerable: from iPhone 4S (A5 chip) to iPhone 8 and iPhone X (A11 chip). https://t.co/dQJtXb78sG

— axi0mX (@axi0mX) 27 September 2019

С помощью Checkm8 можно установить непривязанный джейлбрейк и откатиться на предыдущую версию iOS. Но разработчикам понадобится время, чтобы создать соответствующие инструменты.

Ещё одной особенностью Checkm8 является поддержка всех версий iOS. Эксплойту неважно на какой системе работает устройство, потому что он использует аппаратную, а не программную ошибку.

Checkm8 нельзя запустить на iPhone и iPad с чипом A12 и A13. Вероятно, Apple исправила эту уязвимость в новых процессорах. [MacRumors]

Источник: iphones.ru

Читайте также  Это новые фото AirPods 3. Ждём релиз в марте
Оцените статью
Бизнес Наука
Добавить комментарий